Back to overview
Downtime

Platform Outage

Oct 20 at 02:08pm EDT
Affected services
Account Systems
Donors
Search
Upload
Export
Autocomplete
Site

Resolved
Oct 20 at 04:44pm EDT

Upload has recovered. The entire platform is now operational, and we are continuing to monitor as AWS recovers. Please reach out to support if you experience issues.

Updated
Oct 20 at 02:36pm EDT

The platform is beginning to come back online, with most actions working except upload. We expect upload to return in the coming hours.

Created
Oct 20 at 02:08pm EDT

We are aware that customers are unable to use the DonorAtlas platform due to the large outage of Amazon Web Services. Your data is secure, and we will restore the platform as quickly as possible.